Cisco Cube to Twilio Sample config

version 15.5
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname CLT-CUBE-01
!
boot-start-marker
boot-end-marker
!
!
! card type command needed for slot/vwic-slot 0/1
logging queue-limit 10000
logging buffered 10000000
logging rate-limit 10000
enable secret 5 ***************************
!
aaa new-model
!
!
aaa authentication login AAA_Local local
!
!
!
!
!
aaa session-id common
ethernet lmi ce
clock timezone est -5 0
!
!
!
!
!
!
!
!
!
!
!
!
ip domain name capitano-one.com
ip name-server 10.1.10.10
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
stcapp ccm-group 1
stcapp
!
stcapp feature access-code
prefix *#
call forward all 2
call forward cancel 9
!
stcapp feature speed-dial
!
!
!
stcapp supplementary-services
port 0/3/0
fallback-dn ***************
!
!
!
cts logging verbose
!
!
voice-card 0
dsp services dspfarm
!
!
!
voice service voip
ip address trusted list
ipv4 54.172.60.0
ipv4 54.84.237.137
ipv4 54.85.131.135
ipv4 10.1.100.0 255.255.255.0
ipv4 54.172.60.0 255.255.254.0
ipv4 54.171.127.192 255.255.255.192
ipv4 54.65.63.192 255.255.255.192
ipv4 54.169.127.128 255.255.255.192
ipv4 54.252.254.64 255.255.255.192
ipv4 177.71.206.192 255.255.255.192
ipv4 104.12.254.48 255.255.255.255
ipv4 34.203.250.0 255.255.254.0
address-hiding
dtmf-interworking rtp-nte
mode border-element license capacity 500
allow-connections sip to sip
fax protocol pass-through g711ulaw
sip
bind control source-interface GigabitEthernet0/0.100
bind media source-interface GigabitEthernet0/0.100
header-passing
error-passthru
registrar server expires max 3600 min 600
midcall-signaling passthru media-change
early-offer forced
!
!
voice class uri Twilio sip
host ************
host ipv4:54.X.X.X
!
voice class uri LAB sip
host ipv4:10.1.100.20
host ipv4:10.1.100.21
voice class codec 10
codec preference 2 g711ulaw
!
voice class codec 900
codec preference 2 g711ulaw
!
!
!
voice class e164-pattern-map 10
description *** e164 patterns for INBOUND calls to LAB via Twillio SIP ***
e164 +1704XXXXXXX
e164 +1980XXXXXXX

!
!
voice class e164-pattern-map 900
description *** e164 patterns for outbound calls to Twillio via SIP ***
e164 .T
!
!
voice class server-group 10
ipv4 10.1.100.20 preference 1
ipv4 10.1.100.21 preference 2
description *** LAB CUCM for INBOUND calls in CLT ***
!
voice class server-group 900
ipv4 X.X.X.X
description *** Twilio SBCs for OUTBOUND calls ***
!
voice class sip-options-keepalive 1
description Target Unified CM
transport tcp
!
!
voice iec syslog
!
!
voice translation-rule 1
rule 1 /^/ /+1/
!
!
voice translation-profile twilio
translate called 1
!
!
!
license udi pid CISCO2911/K9 sn
hw-module ism 0
!
hw-module pvdm 0/0
!
hw-module pvdm 0/1
!
hw-module sm 1
!
!
!
vtp mode transparent
username

redundancy
!
!
!
!
!
vlan 10
!
!
!
!
!
!
!
!
!
!
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/0.10
encapsulation dot1Q 10
ip address 10.1.10.254 255.255.255.0
!
interface GigabitEthernet0/0.11
encapsulation dot1Q 11
ip address 10.1.11.254 255.255.255.0
!
interface GigabitEthernet0/0.100
encapsulation dot1Q 100
ip address 10.1.100.254 255.255.255.0
!
interface GigabitEthernet0/0.200
encapsulation dot1Q 200
ip address 10.1.200.254 255.255.255.0
!
interface GigabitEthernet0/0.1721
encapsulation dot1Q 1721
ip address 172.16.1.254 255.255.255.0
!
interface GigabitEthernet0/0.1722
encapsulation dot1Q 1722
ip address 172.16.2.254 255.255.255.0
!
interface GigabitEthernet0/0.1723
encapsulation dot1Q 1723
ip address 172.16.3.254 255.255.255.0
!
interface ISM0/0
no ip address
shutdown
service-module fail-open
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/2
no ip address
shutdown
duplex auto
speed auto
!
interface ISM0/1
no ip address
!
interface GigabitEthernet1/0
ip address 1.1.1.1 255.255.255.0
!
interface GigabitEthernet1/1
no ip address
!
interface Vlan1
no ip address
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 10.1.10.1
!
logging trap debugging
!
!
snmp-server community
!
!
!
control-plane
!
!
voice-port 0/3/0
timeouts initial 60
timeouts interdigit 60
timeouts ringing infinity
timing hookflash-in 150 110
description ***Cordless***
caller-id enable
!
voice-port 0/3/1
!
!
!
!
!
mgcp
mgcp call-agent clt-uc-cucm-sub-1 2427 service-type mgcp version 0.1
mgcp dtmf-relay voip codec all mode out-of-band
mgcp rtp unreachable timeout 1000 action notify
mgcp modem passthrough voip mode nse
mgcp package-capability rtp-package
mgcp package-capability sst-package
mgcp package-capability pre-package
no mgcp package-capability res-package
no mgcp package-capability fxr-package
no mgcp timer receive-rtcp
mgcp sdp simple
mgcp fax t38 inhibit
no mgcp explicit hookstate
mgcp rtp payload-type g726r16 static
mgcp bind control source-interface GigabitEthernet0/0.100
mgcp bind media source-interface GigabitEthernet0/0.100
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
sccp local GigabitEthernet0/0.100
sccp ccm 10.1.100.20 identifier 1 priority 1 version 7.0
sccp ccm 10.1.100.21 identifier 2 priority 2 version 7.0
sccp
!
sccp ccm group 1
bind interface GigabitEthernet0/0.100
associate ccm 1 priority 1
associate ccm 2 priority 2
associate profile 4 register CLT-CUBE-MTP2
associate profile 2 register CLT-CUBE-XCDR
associate profile 1 register CLT-CUBE-CFB
associate profile 3 register CLT-CUBE-MTP
registration timeout 3
keepalive timeout 3
connect interval 3
switchback method graceful
!
ccm-manager music-on-hold
!
ccm-manager redundant-host clt-uc-cucm-pub
ccm-manager mgcp
no ccm-manager fax protocol cisco
ccm-manager config server 10.1.100.20
ccm-manager config
ccm-manager sccp local GigabitEthernet0/0.100
ccm-manager sccp
!
dspfarm profile 2 transcode
codec g729abr8
codec g729ar8
codec g711alaw
codec g711ulaw
codec g729r8
codec pass-through
maximum sessions 8
associate application SCCP
!
dspfarm profile 1 conference
codec g729br8
codec g729r8
codec g729abr8
codec g729ar8
codec g711alaw
codec g711ulaw
maximum sessions 2
associate application SCCP
!
dspfarm profile 3 mtp
codec g711ulaw
codec pass-through
maximum sessions software 32
associate application SCCP
!
dspfarm profile 4 mtp
codec g729r8
maximum sessions software 32
associate application SCCP
!
dial-peer voice 11 voip
huntstop
preference 1
max-conn 100
session protocol sipv2
session server-group 10
destination e164-pattern-map 10
voice-class sip bind control source-interface GigabitEthernet0/0.100
voice-class sip bind media source-interface GigabitEthernet0/0.100
dtmf-relay rtp-nte sip-kpml sip-notify
codec g711ulaw
no vad
!
dial-peer voice 901 voip
translation-profile outgoing twilio
destination-pattern .T
session protocol sipv2
session target sip-server
voice-class sip bind control source-interface GigabitEthernet0/0.100
voice-class sip bind media source-interface GigabitEthernet0/0.100
dtmf-relay rtp-nte sip-kpml sip-notify
codec g711ulaw
no vad
!
dial-peer voice 999030 pots
service stcapp
port 0/3/0
!
!
gateway
media-inactivity-criteria all
timer receive-rtcp 5
timer receive-rtp 1200
!
sip-ua
authentication username xxxxxxxxx password 7  realm sip.twilio.com
registrar dns:XXXXX.pstn.us1.twilio.com expires 3600
sip-server dns:XXXXXX.pstn.us1.twilio.com
!